Dear Linux Vendors: Stop shoving IPv6 down my throat!

I’m a *nix admin by trade. I work in support of infrastructure services and research at a University. My group also handles issues that grad students have that might be keeping them from getting research done. There are many, many of these researchers using some form of Linux to get their work done, and the biggest problem they’ve had has to do with IPv6.



By default, SuSE, Fedora and Mandrake have decided to enable IPv6. This has caused numerous problems, all of which are fixed by disabling IPv6. The question then becomes “why the hell is it enabled in the first place?”.

I have worked in both corporate and academic/research environments. I work in a place that is involved with some very intense and high profile research into network-related protocols, devices and internetworking mechanics. However, I have never received an email from any research or development group demanding IPv6. That being the case, you can imagine how many end-user-types have requested IPv6. A vast majority of non-CS types have no idea what IP even is, let alone that it has versions.

I’ve been using Linux on my desktop for about 5 or 6 years now. I have never required IPv6 for anything. Over these past several years, I have frequented many forums and google groups, and joined a few dozen mailing lists. I have not ever witnessed a post from a frustrated user trying desperately to enable ipv6 and get it working. However, since this recent onslaught courtesy of the Linux distros, the forums and newbie lists are absolutely flooded with problems with name resolution, slow network connections, and “Mozilla slow” postings. These are all fixed by disabling IPv6.

Nothing *requires* IPv6 that I’m aware of, and I use *a lot* of various types of applications, ranging from mundane services like LDAP, DHCP and CUPS, to slightly more exciting things like Apache and MySQL, to cool stuff like music streaming apps and multimedia recording and editing tools, high performance clustering apps, and I’ve even tested P2P apps for others. From the desktop to the server to the cluster, IPv6 is simply NOT a necessity. Please, please, please, disable it. If I need it, I know where the modules.conf file is.

Thanks.